本站所发布的全部内容源于互联网搬运,仅限于小范围内传播学习和文献参考,请在下载后24小时内删除,如果有侵权之处请第一时间联系我删除。

量比选股公式源码

发布于:2022-08-28 13:00:06 阅读量: 分类:股票知识 编辑:探其金融小编 首发 内容来源:探其金融
摘要:量比选股公式源码 1 自从分享了10日资金出入表源码,有朋友私信能否分享一个“成交量占流通盘百分比”指标。没啥好说的,安排[灵光一闪]! 这个分时“成交量占流通盘百分比”幅

特别提醒,本文仅供参考,不作为实操建议,投资决策需建立在独立思考之上,交易风险自担!本站和本人不承担由此产生的一切法律后果!以下是关于量比选股公式源码的内容,希望对大家有用!

量比选股公式源码 1

自从分享了10日资金出入表源码,有朋友私信能否分享一个“成交量占流通盘百分比”指标。没啥好说的,安排[灵光一闪]!

这个分时“成交量占流通盘百分比”幅图指标只为解决成交量变化监控的问题,请勿作为买卖依据!

成交量占流通盘百分比

VAR1:="分时引用.AAQ#DAY";

VAR2:=IF(HOUR<13,TIME-0929-(HOUR-9)*40,TIME-1180-(HOUR-13)*40);

分时量比:SUM(V,VAR2)/(VAR2)/VAR1,COLORWHITE;

竞价金额:=分时引用.竞价金额#DAY,NODRAW;{集合竞价 单位元};

竞额:竞价金额/10000,COLORRED,NODRAW;

竞量:=竞价金额/OPEN/100;

今量:=SUM(V,0),NODRAW;{今天量能,具体到每分钟,可用于分时回看}

昨量:=分时引用.昨量#DAY,NODRAW;{昨天量能}

股本Z:=分时引用.股本Z#DAY;

今换手Z:今量*10000/股本Z,LINETHICK2,COLORCYAN;

DRAWNUMBER(ISLASTBAR,今换手Z,今换手Z),COLORCYAN;

今昨量比:今量/昨量,LINETHICK2,COLORYELLOW;{今日量能与昨天量能比}

DRAWNUMBER(ISLASTBAR,今昨量比,今昨量比),COLORYELLOW;

今开:分时引用.今开#DAY,COLORCYAN,NODRAW;

昨开:分时引用.昨开#DAY,COLORWHITE,NODRAW;

今低:分时引用.今低#DAY,COLORGREEN,NODRAW;

LTP:=IF(CAPITAL<100000,100000,CAPITAL);

竞价换手率:=竞量/LTP*10000;

竞价动能:=今开 * 竞价换手率,COLORYELLOW,NODRAW;

竞价涨停:=分时引用.竞价涨停#DAY,COLORWHITE;

HL:=MAX(HHV(今换手Z,240),HHV(分时量比,240));

NOTEXT昨量线:1,DOTLINE,LINETHICK1,COLORLIGREEN;

NOTEXT活跃线:3,DOTLINE,LINETHICK1,COLORMAGENTA;

NOTEXT高潮线:IF(HL>=7,7,DRAWNULL)DOTLINE,LINETHICK1,COLORRED;

STICKLINE(CROSS(今昨量比,1),0,HL/2,2,0),COLORRED;

DRAWTEXT(CROSS(今昨量比,1),HL/2,' 平量')COLORMAGENTA;

STICKLINE(CROSS(今昨量比,2),0,HL/2,2,0),COLORRED;

DRAWTEXT(CROSS(今昨量比,2),HL/2,' 倍量')COLORMAGENTA;

STICKLINE(CROSS(今昨量比,3),0,HL/2,2,0),COLORRED;

DRAWTEXT(CROSS(今昨量比,3),HL/2,' 高量')COLORMAGENTA;


V1:=REF(今量,BARSCOUNT(C)-0);{开盘9:30分钟量能}

V5:=REF(今量,BARSCOUNT(C)-5);{开盘前5分钟量能}

V10:=REF(今量,BARSCOUNT(C)-10);{开盘前10分钟量能}

V15:=REF(今量,BARSCOUNT(C)-15);{开盘前15分钟量能}

V30:=REF(今量,BARSCOUNT(C)-30);{开盘前15分钟量能}

涨停:=分时引用.涨停1#DAY;

首次涨停:=BARSSINCE(H=涨停);

首次涨停前总量:=SUM(V,0)-SUM(V,首次涨停);

首停昨比:首次涨停前总量/昨量,COLORRED,NODRAW;{首次涨停量能与昨天量能比}

HS0:=STRCAT('9:25→',STRCAT(CON2STR(竞量*10000/FINANCE(46),2),''));

HS1:=STRCAT(' 9:30→',STRCAT(CON2STR(V1*10000/FINANCE(46),2),''));

HS2:=STRCAT(' 9:35→',STRCAT(CON2STR(V5*10000/FINANCE(46),2),''));

HS3:=STRCAT(' 9:40→',STRCAT(CON2STR(V10*10000/FINANCE(46),2),''));

HS4:=STRCAT(' 9:45→',STRCAT(CON2STR(V15*10000/FINANCE(46),2),''));

HS5:=STRCAT(' 10:00→',STRCAT(CON2STR(V30*10000/FINANCE(46),2),''));

HS6:=STRCAT(' 首停→',STRCAT(CON2STR(首次涨停前总量*10000/FINANCE(46),2),'%'));

换手Z:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(HS0,HS1),HS2),HS3),HS4),HS5);

DRAWTEXT_FIX(ISLASTBAR,0.0,0.0,0,STRCAT('换手Z(%):',换手Z)),COLORLIRED;

LB0:=STRCAT('9:25→',STRCAT(CON2STR(竞量/昨量,2),''));

LB1:=STRCAT(' 9:30→',STRCAT(CON2STR(V1/昨量,2),''));

LB2:=STRCAT(' 9:35→',STRCAT(CON2STR(V5/昨量,2),''));

LB3:=STRCAT(' 9:40→',STRCAT(CON2STR(V10/昨量,2),''));

LB4:=STRCAT(' 9:45→',STRCAT(CON2STR(V15/昨量,2),''));

LB5:=STRCAT(' 10:00→',STRCAT(CON2STR(V30/昨量,2),''));

LB6:=STRCAT(' 首停→',STRCAT(CON2STR(首次涨停前总量/昨量,2),''));

LLB:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(LB0,LB1),LB2),LB3),LB4),LB5);

DRAWTEXT_FIX(ISLASTBAR,0.0,0.20,0,STRCAT('今昨量比:',LLB)),COLORLIBLUE;

量比选股公式源码 2

(本文由公众号越声财富(YSLC168888)整理,仅供参考,不构成操作建议。如自行操作,注意仓位控制和风险自负。)

个人认为,过去及未来相当长的时间,短线做强势股,都是实现股市快速增值的大法门。短线资金,是股市种结构性聪明资金、快鱼,其战胜蠢动资金、慢鱼,是市场内在规律决定。而在这内在规律,也同时决定了 这类资金的成功率,只能在10%以内。其实在任何行业,能够活得轻松的,成长快速的,都是这10%的部分。短线做强势股的玩法,把握不好,也是快速寻死的路子。那么下面给大家分享一种实用的量比选股技巧,希望对大家有所帮助。

牛市行情操盘思路

1.大跌一段后,6/12/18均线纠结在一起,量缩后渐放大,长均线在下,指数走平或微升,一根巨量长红启动行情。

2.指数不破6均线,就算破线但线不弯,就算线弯,碰触12均线即反弹,均线多头排列。

3.熊市大跌心悸犹存,恐慌心态需调整,抢反弹转为拉回是买点,资金慢慢回流股市。

熊市行情操盘思路

1.经常出现短多行情,一买就套,必须眼明手快不恋战。

2.反弹就是清仓,保留现金实力。

3.不要挑战大盘,就算逆势股穿头直上,特立独行,终会被大盘拉下。

4.最多保留五分之一资金操作既可,客户赚短价差,营业部赚业绩。

一、首先明确“量比”的概念:

量比:它是指股市开市后平均每分钟的成交量与过去5个交易日平均每分钟成交量之比。量比是衡量相对成交量的指标。在个股K线界面都会显示一个明确的数额,伴随着成交量的变化而变化。

其计算公式为:量比=现成交总手数 /现累计开市时间(分) /过去5日平均每分钟成交量。

在交易软件上,它躲藏在一个不显眼的地方。

量比的分类

量比≦0.5成交量萎缩到极致,变盘随时发生。

量比0.8--1.5成交量处于正常水平。

量比1.5--2.5温和放量,将会延续原有趋势。

量比2.5--5明显放量,可以采取相应行动了。

量比5--10放巨量表现,趋势已到末期。

量比>10极端放量,趋势已经到默契,可以考虑反向操作。

二、操作方法::

中线思想:以成交量为中心,配合大盘行情来控制好仓位。从股价、K线、MACD、题材热度、主力资金、分时成交等综合分析,快速抓涨停。解析一只股,熟手应该在30秒内完成(这需要实战经验和盘感)

1、圈定范围:早盘10点之后(至少半小时的稳定成家才最真实),范围就是量比最大,排名在前80位的股票。然后就在这80只股票里面,选出涨幅在2%——5%的股票加入自选,初步圈定范围。

然后打开涨幅排行榜,点击量比,进行量比排名,加入自选股

2、批量剔除:把这些股票都加入自选股之后,通常还会剩50只左右。这时候,剔除掉流通市值大于100亿的股票,盘子太大就容易冲高回落,尽量规避。

3、个股剔除

再次缩小范围之后,我们需要给个股剔除。

(1)逐一看K线图,剔除掉已经放量两天及以上的个股。这种股已经有了一定启动,如果你是第三天放量才进入的话,相对安全性就不高了。如图,第三天如果介入,第四天就变得弱势。

(2)剔除明显破位下跌趋势中的反弹股。本战法只做盘整之后启动,或明显震荡上升趋势中的股,所以基于概率原则,超跌反弹的股票就不看了。

(3)重点剔除:当天高开低走得股票,以及,高开之后拉升,然后低跌破开盘价的股,如下图:

(4)剔除在股价稳定阶段,卖方委托盘明显较重的股票,可以委比-30%作为参考界限。(注意,一定是股价稳定阶段,股价上拉或下砸的时候情况复杂,不能因此一概而论)

4、优选形态。

剔除了不合条件的股票之后,剩下的股票就是我们买股范围了。但是并不是所有的股票都能买,我们需要从中挑选出好的形态和其他条件最好的股票来进行买入

(1)股价长期横盘,并且成交量一直萎缩在一个区间内的股票,当体突然量能大增,并且符合选股条件的。如下图:

(2)当日股价已经一阳穿多线,或者继续大涨就能够一阳穿多线的。(5日、10日、20日)

(3)该股题材是当日热点板块,并且涨幅位居板块前三名的,或股票本身就有利好。

5、买入时机:

选好目标股之后,就要合理掌握买入时机,增加成功率和安全性

(1)以股价回踩分时均线,获得强支撑的时候买入。

(2)股价放量突破5日线的时候买入

(3)关键低位或上方重压卖单,被强势突破的时候买入。

6、卖出时机:

(1)股价有效跌破5日线的之后就是卖出时机了。

(2)股价冲高之后,快速回落3%以上就可以卖出了。

(3)成交量明显萎缩,人气不够的时候就可以卖出。

(4)长时间徘徊在当日分时均线下方的时候就可以卖出

(5)到达你的盈利目标。

三、量比选股技巧:

首先在操作软件中找到“量比”数据栏,查看所选股票的“量比”数据

明确“量比”的概念:

量比≦0.5,成交量萎缩到极致,变盘随时发生。

量比0.8—1.5,成交量处于正常水平。

量比1.5—2.5,温和放量,将会延续原有趋势。

量比2.5—5,明显放量,可以采取相应行动了。

量比5—10,放巨量表现,趋势已到末期。

量比>10,极端放量,趋势已经到末期,可以考虑反操作

开盘前量比选股5部曲

第一步、9:25竞价结束后,对量比进行排行,看前30名,涨幅在4%以下的股票;

第二步、选择流通股本数量较小的,最好在3亿以下的股票,中小板佳;

第三步、选择之前换手率连续多日在3%以下或连续几日平均换手率在3%以下的个股;

第四步、选择之前多日成交量较为均衡或有涨停未放量现象的个股【之前一直无量涨停的个股除外】

第五步、最好选择个人曾经操作过的、相对比较熟悉的个股进行介入作。

四、量比选出来的个股要兼顾这几点:

1、连续一字板过后的开板股量比都比较大,这个只能凭人品靠

颜值,风险较大自己把握不是本文重点,如新股和复牌股的开板;

2、刚放量:前面没有过明显放量,首日刚开始放量

3、刚起涨:前面没有连续大涨过,首日刚开始大涨

4、左边近距离之内没有明显的高点压力,没有沉重的套牢盘;

5、也就是一个相对底部区域的刚放量上涨股,这种股票才相对安全。

五、实战案例

1、中润资源(7月6号)

当天十点之后,经过筛选,最后确定了中润资源是备选股。在看形态,该股经历了长期的股价盘整,成交量萎缩,于当日巨量上涨,并且在在盘就一阳穿四线。当时有色金属也是龙头板块。所以就成为了优先股。

在股价冲高回踩分时均线获得支撑的时候,买入!当天就收获涨停板,次日再次涨停。

最后分享通达信分时图下的量比指标有图源码

TT:=IF(HOUR>12,(HOUR-13)*60+MINUTE+120,(HOUR-9)*60+MINUTE-30);

P:=IF(ISLASTBAR,BARSLAST(TT=1),0);

T:=BACKSET(P,P+1);

VV:=IF(T=1,V,0);

量比:100*DYNAINFO(17)*(SUM(VV,TT)/TT)/(DYNAINFO(8)/FROMOPEN);

人常常会绝处逢生,再多的艰难困苦,在它面前似乎都只是“摆设”,能以很轻松的态度绕过前行。可能吗?不可能吗?一切都在于你自己是否想去争取,是否想去拥有。人生就像杯中酒,会喝的人是享受,不会喝的人是受罪,喝的人不同,各种滋味亦不同。以上的量比技巧分享希望对大家有收获,助你股海长虹。

如果您喜欢以上文章,或者想了解更多股市投资经验及技巧,可以关注公众号越声财富(YSLC168888),干货满满!

广东广播电视台全资国有企业,全国广电系统唯一专业证券咨询机构(资格证编号:ZX0027),提供每日实战盘面解读,技术实战培训、投资情报。

量比选股公式源码 3

(大家好,我是稳健投资人。这里会向你分享股市投资的知识和干货,如果你感兴趣,请点击上方的“关注”,方便下次快速找到我。)

一、低位板块指数跟踪

2022年2月10日早上6:18时在头条发布了《稳健投资人的选股思路之一:如何寻找还处于低位的股票?》一文,九个交易周下来,我们先来盘点一下,七个低位板块的涨跌情况:

九个交易周下来,跑赢上证指数的板块有4个,其中房地产板块跑赢上证指数19.11个百分点;跑输上证指数的板块有3个,其中运输设备板块和电信运营板块跑输上证指数差不多个2个百分点。

本周三个交易日,三大指数均走出高开低走探底回升走势,沪指走得强一些,周五收盘3251.85站在20日均线上方且在区间振荡小平台上方,这主要得益于房地产、建筑和银行等权重板块的坚挺;而深成指是期间跌破过震荡小平台而收盘仍收在小平台内,只是在小平台的下沿,创业板指则要逊色一些,跌破了振荡小平台且收盘收在小平台的下方。


上一期低位板块跟踪(2022-4-5发布)的文章里,阐明了我对后期的展望,现在依然坚持这个观点,即今年只关注2015年行情后一直没有起来过的板块,在这些低位板块中寻找基本面没问题的低位个股进行操作。

二、关于量比的探讨

关于量比,一直有条友留言,要我写个量比的选股公式。那今天我们就来聊聊量比吧。

(一)量比的定义:

量比是衡量相对成交量的指标。它是指股市开市后平均每分钟的成交量与过去5个交易日平均每分钟的成交量之比。

其计算公式为:

量比=(现成交总手数 / 现累计开市时间(分) )/ 过去5日平均每分钟成交量

(二)量比指标的市场含义:

量比这个指标所反映出来的是当前盘口的成交力度与最近五天的成交力度的差别,这个差别的值越大表明盘口成交越趋活跃,从某种意义上讲,越能体现主力即时做盘,准备随时展开攻击前蠢蠢欲动的盘口特征。

量比反映出的主力行为,从计算公式中可以看出,量比的数值越大,表明了该股当日流入的资金越多,市场活跃度越高;反之,量比值越小,说明了资金的流入越少,市场活跃度越低。

一般来说:

量比≦0.5,成交量萎缩到极致,变盘随时发生;

量比0.8—1.5,成交量处于正常水平;

量比1.5—2.5,温和放量,将会延续原有趋势;

量比2.5—5,明显放量,可以采取相应行动了;

量比5—10,放巨量表现,趋势已到末期。

(二)量比选股公式:

我试图按照以上的定义去写量比公式,但很难写出符合定义的公式,主要卡在“现累计开市时间(分)”上。

在通*信的[插入函数]中的“即时行情函数”中有专门的函数,即时量比函数:DYNAINFO(17) ,是即时行情数据。

极短线的根据量比选股的方法是:

早上集合竞价结束后,按量比将所有股票(或你感兴趣的股票)进行排序,选择量比大于2的、涨幅在2%至4%之间的股票,然后回到这些个股的K线图上,看看这些个股所处的位置和形态,再看看个股的基本面,从而选择2至3只做为买入的备选。

将这样的思路写成下面的即时选股公式,由于该公式用的是即时数据,所以盘后用这个选股条件是选不出股票的。

量比选股公式1:(此公式是用于盘中选股的)

…… …… …… …… ……

涨幅:=DYNAINFO(14);(即时涨幅)

量比:=DYNAINFO(20);(即时量比)

XG:涨幅>2 AND 涨幅<4 AND量比>2.5;

…… …… …… …… ……

备注:这种方法我以前也用过,只能说理想很丰满,现实很骨感,在9:25至9:30这短短5分钟就匆忙定下要买的股票,心理上承受的压力是很大,而且成功并不像想象中的那么高,所以后来这种方法被我舍弃了。

还有一个是利用当日成交量和前5日的平均成交量求比值,得到一个类似于是量比的公式如下:

量比选股公式2:(此公式是用于盘后选股的)

…… …… …… …… ……

量比:=V/REF(MA(V,5),1);

涨幅:=(C-REF(C,1))/REF(C,1)*100;

选股:量比>1.8 AND 涨幅>0 AND 涨幅<2;

…… …… …… …… ……


当股价大幅下跌后,出现“量比选股公式2”的信号,就说明有资金在悄悄地干活了。


还是那句话,还在低位的、基本面没问题的个股,如果出现满足“量比选股公式2”的,倒也是可以考虑的。

上面的公式只有一个输出语句,所以它既可以是指标公式,也可以是条件选股公式。


以上是用昨天的收盘价选出的股票,共有23只,因为在这里发文不能出现股票名称,所以大家自己去选选看吧。

我看了一下,确实还有在低位的、基本面没问题的股票,大家用心去发掘吧。

好了,今天就写到这里了,朋友们再见!

(原创不易,欢迎朋友们点赞、收藏、转发、打赏!予人玫瑰,手有余香!谢谢!!)

免责声明: 本站所有内容均来自互联网渠道,不代表探其金融观点及立场,转载请保留链接: 量比选股公式源码:http://www.00is.com/gupiao/1352318.html

今日最新

热门浏览